
Campaign Cartographer 2 Tutorial 
Creating Local Maps from Regional Maps 

Local Map Tutorial 
After creating a large, regional map of their campaign, many GMs want to render small, local 
maps from the larger whole. This tutorial covers one of many methods of accomplishing this 
goal. 

Assumptions 
This tutorial makes a few assumptions about your CC2 installation and the nature of your 
regional map: 

• This tutorial was written using Campaign Cartographer 2 Pro, v. 6.12, with the Universal 
Update v. 8 

• Your map border is a rectangle 
• The border rectangle is on the MAP BORDER layer 
• You have experience with standard Windows dialogue boxes 

Conventions 
To clarify instructions, the following conventions are used: 

• Commands are referenced by their names, noted in Bold Type; text equivalents are noted 
in brackets following the command. If desired, you can invoke the command with its icon 
button, but due to possible differences in an installation’s icon bar layout, these buttons are 
referenced in this tutorial. 

• Dialogue box command buttons and fields are referenced by their names, noted in Bold 
Type. 

• Menu commands are separated with “->” and noted in Bold Type (e.g., File -> Save As... 
means open the File Menu and click on the Save As... command). 

• Map layers are referenced in BOLD CAPITAL LETTERS. 
• Select means that you click on a map entity with the left mouse button. 
• Command line refers to CC2’s command line, located at the lower left of the CC2 window. 
• Italic text refers to author notes. 

Getting Started 
While not absolutely necessary, it’s a helpful to know your campaign map’s dimensions and to 
have an idea of how big you want your local map to be. These values will aid in some 
calculations made in the instructions below, and typically grants greater precision in your final 
result. 
 
In this tutorial, I am using my big campaign map of Trid. The campaign map is quite large, 
measuring 2,030 miles east to west and 1,700 miles north to south. I want to create a local map 
of a particular area, and for the sake of example, I want my local map to measure 100 miles 
across, though I’m not particular about the north/south distance.. 
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Creating the Local Map 
1. Open your campaign map in CC2.  
2. Use Zoom Extents (Zext) to zoom out to the map’s extents. 
3. Use File -> Save As... to save your map with a new name. This lets you work with a copy 

of your original map.  
4. Type the name of your new map in the File Name field; I suggest using the name of your 

local area. 
5. Click Save to save the map with the new name.  
 
I’ve opened my campaign map of Trid to create a detail map of the Trollmarche River delta 
along the southern border of Nador, a nation along the West coast. I save a copy of my 
original map with the name “nador.fcw”. 
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6. Open the Map Layers dialogue box with the Select Layer button on the top toolbar. 
Alternately, you may use Tools -> Set Properties -> Layers... 

7. Select the left-most box next to the MAP BORDER layer to make the MAP BORDER 
layer current.  

8. Click the Freeze All button to freeze the other layers. An “F” will appear in the right-
most box next to each layer; this means that layer is frozen and cannot be selected, edited, 
or deleted.  

9. Click OK to clear the Select Layer dialogue box and return to the map. 
 
You’re setting things up to resize the map border rectangle, giving you a “frame” to help you 
select the area you want to detail. The reason you need to freeze the other layers is because 
when you do your resizing, you want to affect only the MAP BORDER layer. 
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10. Invoke the Scale (Sca) command. The command line reads: 
“Select entities (0 picked) [Dialog]:” 

11. Right-click. 
12. Select All. 
13. The MAP BORDER turns grey, indicating that it is selected.  
14. Right-click. 
15. Select Do It. 
16. The command line reads “Scale Origin”.  

CC2 is asking you to identify the point at which the scale change is anchored.  
17. Type “0,0” to indicate the lower left corner of the map. Press Enter. 
18. The command line reads “Scale to (Shift=Change ref, Ctrl=Independent X/Y)”. 

CC2 is asking you for a scale factor (numbers greater than “1” increase size; numbers 
between zero and “1” decrease size). You can enter a formula for precision values. We 
want a local map 100 miles across, and our campaign map is 2,030 miles wide, so we’ll 
type an expression that evaluates to the correct scale factor. 

19. Type “100/2030” and press Enter to resize the MAP BORDER and return to the map. 
 

 
 
Note the small rectangle to the right of the scale bar. This is the new, resized MAP 
BORDER, which you can use as a “window” through which you may view your local map. 
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20. Invoke the Move (Mov) command. The command line reads: 
“Select entities (0 picked) [Dialog]:” 

21. Right-click. 
22. Select Layer. 
23. Right-click to open the Select Layer dialogue box. 
24. The MAP BORDER layer should be selected; click OK. 
25. Right-click. 
26. Select Do It. 
27. The command line reads: “Move from point” 

CC2 is going to move the MAP BORDER and needs to know where to move it from. Note 
the cursor has turned into a cross-hair. 

28. Left-click somewhere near the MAP BORDER.  
29. The command line reads: “Place (Shift=15° Rot, Shift+Ctrl=Rot, Ctrl=Scale)” 

You can now visually drag the MAP BORDER to wherever you want. 
30. When you’ve placed the MAP BORDER, left click to place it. 
 

 
 
The area inside the MAP BORDER will become your local map. Before doing anything else, 
though, let’s zoom in to get a better look at what we’re working with. 
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31. Invoke the Zoom Window (Zwin) command. The cursor turns into a cross-hair and the 
command line reads: “Zoom Window:” 

32. Select a point a little above and to the left of the MAP BORDER. 
33. The command line reads: “Opposite corner:” 
34. Select a point a little below and to the right of the MAP BORDER. 

CC2 zooms into the area selected. Now that you have a better view, you may wish to 
reposition the MAP BORDER; if so, repeat Steps 20–30, above. 

 

 
 
You’re looking at the beginnings of your local map, which includes (in this example) some 
coastal area, moors to the west, a river, hills to the east, and two settlements. In the next 
series of instructions, we’ll cut away everything outside the MAP BORDER, leaving just the 
features within the local map “frame.” 
 
 
 
 
 
 
 

6 of 19 
© 2006 Erin D. Smale 

esmale@welshpiper.com 



Campaign Cartographer 2 Tutorial 
Creating Local Maps from Regional Maps 

35. Open the Map Layers dialogue box with the Select Layer button on the top toolbar.  
36. Click the Thaw All button to unfreeze all the layers. The “F” in the right-most box next 

to every layer disappears. 
37. Select the left-most box next to any layer other than MAP BORDER. 
38. Select the right-most box next to the MAP BORDER layer to freeze it; this means that 

the MAP BORDER layer cannot be selected, edited, or deleted. 
39. Click OK to clear the Select Layer dialogue box and return to the map. 

 
You’re paving the way to getting rid of everything outside the MAP BORDER. Freezing 
the MAP BORDER layer prevents it from suffering the same fate you’re about to inflict 
on everything else in your map. 

 

 
 
In the next step, you’re going to erase everything outside the MAP BORDER. If you haven’t 
already done so, save your map with the File -> Save command, or use the CTRL+S 
keyboard shortcut. 
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40. Invoke the Erase (Erase) command. The command line reads:  
“Select entities (0 picked) [Dialog]:” 

41. Right-click. 
42. Select All. 

Chances are that everything in the CC2 window turned grey, obscuring your MAP 
BORDER. That’s alright—we’ll get it back. 

43. Use View -> Redraw or CTRL+R to get your MAP BORDER to reappear. 
44. Right-click. 
45. Select Combine -> Not. 
46. Use the Endpoint (Ept) command. The command line reads: “Entity” 
47. Select a point at the lower left of the MAP BORDER. The command line reads: 

“Opposite corner” 
48. Select a point at the upper right of the MAP BORDER. 

Several map entities will reappear; don’t worry—that’s supposed to happen. 
49. Right-click. 
50. Select Do It. 

The CC2 window may blank out; use View -> Redraw or CTRL+R to redraw the map. 
51. Use Zoom Extents (Zext) to zoom out to the map’s extents. 
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You’ll note several entities outside the MAP BORDER, which is normal. These are entities 
that cross the MAP BORDER. In Step 42, we selected everything except for the MAP 
BORDER and in Steps 45–48, we used Combine -> Not to de-select everything inside the 
MAP BORDER. Because these entities inside the border extend beyond it, they weren’t 
erased.  
 
The entities remaining will be one of three types: 
 
1. Path: These are lines connected to each other at their endpoints. You can Explode a path 

to convert it to lines, but it’s often easier just to Trim away the portion you don’t want.  
In the example above, the red and blue lines, representing a road and a river, 
respectively, are paths. 

2. Polygons: These are filled or unfilled polygons; they may be “unclosed,” then treated 
like paths, above.  
In the example above, the hills along the eastern edge of the MAP BORDER, and the 
dark brown areas to the west and south are filled polygons. 

3. Multipolies: These are similar to polygons, but behave a little differently. To edit a 
multipoly, you must reduce it to its components parts with the Explode command. This 
converts the multipoly into individual lines.  
In the example above, the big, beige blob representing the continental landmass is a 
multipoly. 

 
It’s important to understand the “hierarchy” of CC2 entities. For our purposes, there are 
four types we need to know about: 
• Line: The “lowest” form of CC2 entity; think of it as an “atom”. 
• Path: A series of lines connected at their endpoints. While CC2 treats a path is a single 

entity, it is actually composed of two or more lines. Think of it as an “element.” 
• Polygon: Essentially a closed path whose end points meet. Like a path, it is treated as a 

single entity, but it is actually composed of three or more lines. 
• Multipoly: A single entity composed of lines, paths, and polygons. To extend our analogy, 

think of it as a “compound.”  
 
Editing and erasing these entities is variously accomplished as shown below: 
 

Entity Type Explode Trim Break Erase 
Line n/a Trims line Breaks line Erases line 
Path Converts to lines Trims path Breaks path Erases path 
Polygon Converts to lines n/a Breaks polygon Erases polygon 
Multipoly Converts to lines n/a n/a Erases multipoly 
 
We’ll start our editing with the multipoly. 
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52. Invoke the Explode (Explode) command. The command line reads:  
“Select entities (0 picked) [Dialog]:” 

53. Select the multipoly. 
54. The multipoly turns grey, indicating that it is selected.  
55. Right-click. 
56. Select Do It. 
57. Use View -> Redraw or CTRL+R to redraw the map. 

The multipoly turns into an outline and its fill disappears—it’s now just a set of lines. 
 

 
 
With the multipoly converted to lines, you can begin erasing those portions outside the MAP 
BORDER. 
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58. Invoke the Erase (Erase) command.  
59. Right-click. 
60. Select Window. The cursor turns into a cross-hair and the command line reads:  

“pick entities in a window” 
The Erase by Window command lets you delete everything inside a rectangle you draw. 

61. Select a point to represent the upper left corner of your rectangle. 
62. Select a point to represent the lower right corner of your rectangle. 

Take care to select only the lines created by your exploded multipoly. 
63. Right-click. 
64. Select Do It. 

Everything in your Erase window disappears.  
 

 
 
My Erase window started at the upper-left corner of the map and extended down and to the 
right. The result erased the upper-left corner of what used to be my multipoly. Repeat steps 
58–64 until every bit of the exploded multipoly outside the MAP BORDER is gone; do the 
same with any other multipolies you may have, using Zoom Window and Zoom Extents to do 
some detailed erasing or see how much is left outside your MAP BORDER. Finally, make 
sure you don’t erase anything inside the border, since you’ll need those entities for the local 
map. Next, we’ll work on the polygons. 

11 of 19 
© 2006 Erin D. Smale 

esmale@welshpiper.com 



Campaign Cartographer 2 Tutorial 
Creating Local Maps from Regional Maps 

65. Invoke the Edit (Edit) command. The command line reads:  
“Entity to edit:” 

66. Select a closed polygon. 
The Edit 2D Polygon dialogue box opens. 

67. Uncheck the “Closed” entry in the Options frame 
68. Click OK to return to the map. 

The closed polygon is converted to a single path; any fill style disappears. 
69. Explode the path you just made. 

The path is reduced to its component lines. 
 

 
 
In my example, map, I had to “unclose” the hill area along the eastern edge of the MAP 
BORDER, along with the dark brown patches that represented moors and heath on the 
larger campaign map. Repeat steps 65–69 until all the polygons that cross your MAP 
BORDER are “unclosed” and converted to lines. Again, use Zoom Window and Zoom 
Extents for detail work and gauge how much is left outside your MAP BORDER.  
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When you’re done, use the Erase command to get rid of lines outside the border. When 
you’re done, use Zoom Extents: you should be left with a MAP BORDER and a set of lines 
(and possibly some text labels, as shown on the example below): 
 

 
 
You can see the remains of both the the multipoly and polygons inside the MAP BORDER. 
The light brown lines represent what’s left of the moors, heath, and hill areas, and when we 
get to actually editing the detail map, these will mark the edges of those terrain types. 
 
The last bits to edit at this point are the road (red path) and river (blue path). Instead of 
simply chopping them off with the Break command, we’ll incorporate some finesse and Trim 
them precisely so their endpoints rest on the MAP BORDER. 
 
To do this with some precision, use Zoom Window to get a closer look at where these paths 
cross the MAP BORDER. 
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70. Invoke the Trim to Entity (Trimto) command. The command line reads:  
“Select entity to trim to:” 

71. Select the edge of the MAP BORDER crossed by the path. 
Even though the MAP BORDER layer is frozen, it should appear grey when selected. 

72. The command line reads: “Select entity to trim:” 
73. Select a segment of the path you want to trim inside the MAP BORDER. 

The portion of the path outside the MAP BORDER should disappear. 
74. Redraw the map. 

The endpoint of the path should lie on the MAP BORDER. 
 

 
 
As shown above, my river path is now trimmed to the MAP BORDER. Repeat Steps 70–74 
with any other paths that extend beyond the MAP BORDER. When you’re finished, use 
Zoom Extents to make sure there are no more entities outside the MAP BORDER. 
 
Let’s also take a moment to deal with text labels—they’re too large for the local map. In the 
next step, we’ll reduce them to manageable size and keep them inside the MAP BORDER. 
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75. Invoke the Edit (Edit) command.  
76. Select one of the text labels. 

The Edit Text dialogue box opens. 
77. Click on the Properties button. 

The Text Properties dialogue box opens. Look for the Height field in the upper left. 
78. Enter a new, smaller value in the Height field. 

The value you enter is a matter of map scale and your taste for proportion. If you want, 
you can simply enter a number and see how it looks. 
 
But if you want to keep the new text size relative to the original map, you should apply 
the scale factor you used when you resized the MAP BORDER (Step 19). In this case, the 
value is (100/2,030). 
 
Now, before you get out your calculator, understand that CC2 lets you enter a formula in 
the Height field. The formula you want to use multiplies the current value by the scale 
factor, and the expression to enter in the Height field is something like this: 
 
[current height] * (100/2030) 

79. Click OK to return to the map. 
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When the map reappears, the text label is resized. It may not appear exactly where you want 
it, but you can fix this with the Move command (as I’ve done in the figure below). Repeat 
Steps 75–79 with the remaining text labels, then Zoom Extents: Your map should now fill 
CC2’s editing window. 
 

 
 
Things are starting to come together on your local map, though there’s still some work to do. 
Specifically, we need to resize the two settlement symbols), the river, and the road.  
 
Before we do this, we need to address a subtle aspect of the local map. When we started, the 
coordinate system of the original campaign map placed the Cartesian point “0,0” at the 
lower-left corner. When you rescaled the map, however, CC2 moved the map’s position on 
the Cartesian grid. As a result, “0,0” no longer references your local map’s lower-left 
corner. We need to bring the map back in line with the grid. 
 
Once again, though, CC2 provides, and we can invoke a simple command to do just that. 
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80. Use View -> Move Origin (Origin). The command line reads, “Origin”. 
CC2 is asking you to select a point that will become the map’s origin (i.e., the Cartesian 
point “0,0”). 

81. Move the crosshair to the map’s lower-left corner. 
82. Left-click on the intersection of the border’s vertical and horizontal axis, inside the MAP 

BORDER. 
The lower-left corner is now the map’s origin, (“0,0”), which makes it easier to perform 
the rescaling we need to do next.  

 
The settlements are represented by symbols, which can be rescaled. The most efficient way to 
rescale symbols is to use the Scale command as described in Steps 10–19. However, when 
selecting entities to scale (Step 12), you can select by Layer. Use the same scale origin 
(“0,0”), but when CC2 asks you to provide a scale factor, don’t use the same value you 
entered in Step 19. Instead, enter this formula: 
 
[map width] / 1000 
 
In this case, you’d enter “100/1000”. You want to do this because CC2’s overland symbols 
are optimally scaled to 1/1000th of a map’s width. When the map reappears, the symbols are 
resized and repositioned, but they’re in proportional distance to one another and, most 
importantly, they’re inside the MAP BORDER. If you hadn’t moved the map origin in Steps 
80–82, they probably would have appeared outside the MAP BORDER, which makes them 
difficult to find, even with Zoom Extents. 
 
Use the Move command to drag the resized symbols to their desired locations. The next step 
is to rescale any roads and rivers. 
 
Because these entities are paths, they’re not resized in the same way as symbols or text. 
Instead, you want to adjust their width so that they conform to the local map’s scale.  
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83. Invoke the Change Width (Changelw) command. The command line reads:  
“Select entities (0 picked) [Dialog]:” 

84. Select any paths representing rivers, roads, trails, borders, etc. 
85. Right-click. 
86. Select Do It. The command line reads: “New line width” 

CC2 is asking for a value to represent the width of the selected paths. To keep everything 
in proportional scale, use the scale factor you entered in Step 19. 

87. Type “100/2030” and press Enter to rescale the selected paths and return to the map. 
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At this point, you’re finished with the fundamentals of creating your local map. It may not look 
like much, but now you have a properly scaled map of the area you wanted to detail, and you can 
use other CC2 editing tools to add details: 
 
• Fractilise coastlines and rivers 
• Convert paths to polygons to create coloured fills for terrain, lakes, and oceans 
• Add symbols 
• Overlay a hex or square grid  
• Add a scale bar and compass rose 
 
These procedures are beyond the scope of this tutorial, but with some additional editing, you 
dress up your local map with detail, as shown on the work-in-progress example below: 
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